Elevated latencies

Incident Report for TRM Labs

Resolved

This incident has been resolved.
Posted Nov 15, 2025 - 17:30 EST

Monitoring

There is no system wide degradation. Core transaction services remain unaffected.
Posted Nov 14, 2025 - 18:43 EST

Update

We are continuing to work on a fix for the issue.
Posted Nov 14, 2025 - 13:02 EST

Identified

We have identified the issue and isolated to a small subset of routes. Next update will be in 12 hours. Core transaction services remain unaffected.
Posted Nov 13, 2025 - 21:10 EST

Update

We are continuing to investigate the issue.
Posted Nov 13, 2025 - 18:51 EST

Update

We are continuing to investigate the issue.
Posted Nov 13, 2025 - 16:20 EST

Update

We are continuing to investigate the issue.
Posted Nov 13, 2025 - 14:05 EST

Update

We have identified potential resource contention on a DB. Continuing to investigate
Posted Nov 13, 2025 - 12:12 EST

Update

We have identified potential resource contention on a DB. Continuing to investigate
Posted Nov 13, 2025 - 11:32 EST

Update

We have identified potential resource contention on a DB. Continuing to investigate
Posted Nov 13, 2025 - 10:53 EST

Update

We are investigating elevated latencies on certain APIs
Posted Nov 13, 2025 - 10:25 EST

Investigating

We are investigating elevated latencies on certain APIs
Posted Nov 13, 2025 - 10:13 EST
This incident affected: Forensics on Web.