The fix for the Graph Visualizer performance issue has been deployed to production. We are monitoring the rollout and verifying that large graphs load and respond normally when customers add or move elements.
Posted Aug 24, 2026 - 17:56 EDT
Update
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Aug 24, 2026 - 17:55 EDT
Monitoring
The fix for the Graph Visualizer performance issue has been deployed to production. We are monitoring the rollout and verifying that large graphs load and respond normally when customers add or move elements.
Posted Aug 24, 2026 - 17:47 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 24, 2026 - 14:44 EDT
Investigating
We are investigating an issue causing Graph Visualizer to load very slowly or freeze when customers add or manipulate graphs.
Posted Aug 24, 2026 - 14:24 EDT
This incident affected: US (US - Forensics on Web) and EU (EU - Forensics on Web).