APIs timing out

Incident Report for TRM Labs

Resolved

This incident has been resolved.
Posted Aug 19, 2025 - 14:26 EDT

Monitoring

We've mitigated the issue. We're continuing to monitor the situation.
Posted Aug 19, 2025 - 14:20 EDT

Investigating

We are investigating timeouts on our Wallet Screening APIs.
Posted Aug 19, 2025 - 14:13 EDT
This incident affected: API (WS2).