Transaction Monitoring Transactions Stuck in Processing

Incident Report for TRM Labs

Resolved

All stale transactions are processed and issued are resolved.
Posted Jan 16, 2026 - 20:21 EST

Monitoring

We have identified and mitigated the issue. We are monitoring to confirm resolution.
Posted Jan 16, 2026 - 19:47 EST

Identified

We have confirmed an issue which has delayed processing of Transaction Monitoring transactions. This has resulted in transactions being stuck in "PROCESSING" on the platform. We are actively root causing.
Posted Jan 16, 2026 - 19:10 EST

Investigating

We are currently investigating reports of transactions suck in processing in our Transaction Monitoring platform.
Posted Jan 16, 2026 - 18:52 EST
This incident affected: US (US - API - Transaction Monitoring).