Resolved: intermittent TRM login issues

Incident Report for TRM Labs

Resolved

The provider restored service, and TRM login access has been restored and validated
Posted Aug 27, 2026 - 07:45 EDT

Monitoring

Some customers and internal users were intermittently unable to log in to TRM for approximately 38 minutes on 27 August 2026, from around 3:15pm to 3:53pm PDT.

The issue was caused by an intermittent outage affecting one of our authentication service providers. The provider has restored service, and TRM login access has been restored and validated. We are continuing to monitor the service.

We apologize for the disruption.
Posted Aug 27, 2026 - 07:36 EDT
This incident affected: US (US - Forensics on Web).