Degraded WS API

Incident Report for TRM Labs

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 14:00 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 10, 2026 - 13:20 EDT

Investigating

We are investigating metrics indicating degraded WS API performance.
Posted Mar 10, 2026 - 13:15 EDT
This incident affected: US (US - API - Wallet Screening).