Wallet Screening performance

Incident Report for TRM Labs

Resolved

This incident has been resolved.
Posted Aug 21, 2026 - 02:21 EDT

Monitoring

We think the impact from the issue is over.
Posted Aug 20, 2026 - 20:54 EDT

Investigating

We are investigating reports of elevated errors and latency affecting wallet screening requests. Our engineering team is reviewing the available data to determine the scope and cause of the issue.

We will provide another update by 6:00pm PDT on 20 August 2026, or sooner if more information becomes available.
Posted Aug 20, 2026 - 20:33 EDT
This incident affected: US (US - API - Wallet Screening) and EU (EU - API - Wallet Screening).