Graph Visualizer degraded performance

Incident Report for TRM Labs

Resolved

All systems continue to look healthy. Resolving the incident.
Posted Aug 26, 2026 - 02:30 EDT

Monitoring

The steps we took to reduce load on the affected database have taken effect, and Graph Visualizer error rates and response times have returned to normal levels.

We are continuing to monitor closely to confirm performance remains stable before marking this resolved.
Posted Aug 26, 2026 - 02:07 EDT

Identified

We have identified the cause of the degraded performance affecting Graph Visualizer, where some requests may be slow or return an error.

A scheduled background data process is placing elevated load on a supporting database, and we are actively working to reduce that load and restore normal performance.
Posted Aug 26, 2026 - 01:49 EDT

Update

We confirmed this degradation was caused by realtime replication lag, which led to realtime query timeouts and elevated 5xx responses on GV fast path endpoints.
We're investigating remediation steps.
Posted Aug 26, 2026 - 01:11 EDT

Investigating

We are investigating ongoing degraded performance affecting Graph Visualizer. Some customers may experience elevated error rates and requests taking longer than usual.

We will provide another update as more information becomes available.
Posted Aug 26, 2026 - 00:25 EDT
This incident affected: US (US - Forensics on Web) and EU (EU - Forensics on Web).