Elevated errors on Forensics

Incident Report for TRM Labs

Resolved

This incident has been resolved.
Posted May 08, 2026 - 13:17 EDT

Update

We are continuing to investigate this issue.
Posted May 08, 2026 - 12:44 EDT

Investigating

The team is investigating an elevated rate of timeouts in the TRM UI.
Posted May 08, 2026 - 12:43 EDT
This incident affected: US (US - Forensics on Web).