Transaction Monitoring API degraded service

Incident Report for TRM Labs

Resolved

Services continue to remain healthy. Resolving.
Posted Jul 17, 2026 - 00:19 EDT

Monitoring

Service is back to 100%. Stuck workers were restarted and no lag is being noticed. Monitoring.
Posted Jul 16, 2026 - 23:23 EDT

Investigating

We're noticing roughly 1% of initial screenings are degraded. We're investigating the issue.
Posted Jul 16, 2026 - 22:39 EDT
This incident affected: US (US - API - Transaction Monitoring).