Slowness and Errors in the EU site

Incident Report for TRM Labs

Resolved

The issue is resolved.
Posted Feb 04, 2026 - 20:06 EST

Monitoring

Risk indicator issues are resolved as well and we see improved performance. Will continue to monitor.
Posted Feb 04, 2026 - 13:59 EST

Update

All errors on Forensics in EU have been resolved. We are looking in to any slowness concerns.
Posted Feb 04, 2026 - 12:54 EST

Identified

We have identified the issue and working on a fix.
Posted Feb 04, 2026 - 11:28 EST

Investigating

We are seeing slowness and some occasional errors in EU Forensics. We are currently investigating.
Posted Feb 04, 2026 - 11:12 EST
This incident affected: EU (EU - Forensics on Web).