Elevated errors on walletscreening

Incident Report for TRM Labs

Resolved

The issues have been resolved.
Posted Jun 16, 2025 - 00:44 EDT

Update

We've mitigated the issues and are continuing to monitor the situation.
Posted Jun 15, 2025 - 23:08 EDT

Monitoring

We're continuing to investigate the issue.
Posted Jun 15, 2025 - 22:59 EDT

Investigating

We're continuing to investigate the issue.
Posted Jun 15, 2025 - 22:31 EDT

Monitoring

We've mitigated the issue. We are continuing to monitor the situation.
Posted Jun 15, 2025 - 22:22 EDT

Update

We are continuing to investigate this issue.
Posted Jun 15, 2025 - 21:52 EDT

Investigating

We are monitoring elevated error rates on WS
Posted Jun 15, 2025 - 21:52 EDT
This incident affected: API (TM2, WS2).