Data freshness issues

Incident Report for TRM Labs

Resolved

This incident has been resolved.
Posted Aug 07, 2026 - 13:48 EDT

Monitoring

We are experiencing some data freshness issues. All services remain available. The team has implemented the fix and we are seeing recovery and are monitoring for further issues.
Posted Aug 07, 2026 - 12:52 EDT

Investigating

We are experiencing some data freshness issues. All services remain available. The team has root caused the issues and is investigating a fix.
Posted Aug 07, 2026 - 12:33 EDT