TRM Web App has Partial Outage

Incident Report for TRM Labs

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 20:44 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2025 - 19:15 EDT

Investigating

Some users are experience issues logging in or already logged in users are not able to access certain pages on the web app.
Posted Apr 14, 2025 - 17:30 EDT
This incident affected: Forensics on Web.