WS API Timeouts

Incident Report for TRM Labs

Resolved

Performance on WS2 and Forensics has recovered.
Posted Aug 21, 2025 - 17:09 EDT

Monitoring

Performance on WS2 and Forensics has recovered. We are continuing to investigate.
Posted Aug 21, 2025 - 15:50 EDT

Update

We are continuing to investigate degraded performance on WS2 APIs and Forensics.
Posted Aug 21, 2025 - 15:30 EDT

Update

We are investigating degraded performance on WS2 APIs and Forensics.
Posted Aug 21, 2025 - 14:31 EDT

Investigating

We are investigating degraded performance on WS2 APIs.
Posted Aug 21, 2025 - 14:09 EDT
This incident affected: Forensics on Web and API (WS2).