At this time, all customer facing APIs are operational.
Posted Jun 10, 2025 - 14:47 EDT
Update
Forensics, Wallet Screen, BlockInt and Detect are now fully operational. We are focussing on bringing the remaining public APIs back online.
Posted Jun 10, 2025 - 14:15 EDT
Update
Forensics, Wallet Screen and Detect are now fully operational. We are focussing on bringing the remaining public APIs back online.
Posted Jun 10, 2025 - 14:13 EDT
Update
Forensics and Detect are now fully operational. We are focussing on bringing public APIs back online.
Posted Jun 10, 2025 - 13:07 EDT
Update
Forensics is now fully operational, and we’re close to restoring our public APIs. We will then shift focus to bringing remaining applications, such as Detect, back online.
Posted Jun 10, 2025 - 11:30 EDT
Identified
Some recovery is underway for our main applications, such as Forensics. Detect, however, is still not fully operational due to the underlying outage.
Posted Jun 10, 2025 - 10:48 EDT
Update
The upstream provider has identified the root cause and is working on a fix. Meanwhile, we continue to focus our efforts on executing a failover to an alternate provider.
Our primary vendor continues to experience a major outage. We are actively progressing with a failover to an alternative provider.
Posted Jun 10, 2025 - 06:48 EDT
Update
We are actively monitoring the ongoing outage with our current provider via Salesforce Status (https://status.salesforce.com/generalmessages/10001540) and are simultaneously working with alternative vendors to implement a failover solution.
Posted Jun 10, 2025 - 05:49 EDT
Update
Our upstream provider, Heroku, is currently experiencing a multi-region outage. We are actively working on implementing a failover solution with an alternative provider to mitigate the impact.
Posted Jun 10, 2025 - 05:05 EDT
Update
Our team is working with the upstream provider to identify the root cause and implement mitigation steps.
Posted Jun 10, 2025 - 04:30 EDT
Update
We are actively working with our upstream provider to mitigate the issue and restore normal service.
Posted Jun 10, 2025 - 03:54 EDT
Update
We are actively continuing our investigation into the outage
Posted Jun 10, 2025 - 03:22 EDT
Investigating
We are investigating outage caused by an upstream provider.
Posted Jun 10, 2025 - 03:03 EDT
This incident affected: Forensics on Web, Detect and API (TM2, WS2, BLOCKINT).