Users unable to switch environments

Incident Report for TRM Labs

Resolved

Issue is fixed
Posted Sep 04, 2026 - 00:03 EDT

Monitoring

We deployed a fix and validated that the environment switch flow now routes correctly and opens the environment switcher, as expected.
Posted Sep 04, 2026 - 00:02 EDT

Investigating

We’re investigating an issue preventing some users from switching between customer environments. Other functionality may be available, but switching environments is currently affected.

As a workaround in the meantime, users can log out and and log back into the environment they wish to switch to.
Posted Sep 03, 2026 - 21:15 EDT