Elevated error rates and latencies on Wallet Screening APIs

Incident Report for TRM Labs

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 28, 2025 - 12:08 EDT

Investigating

We are currently investigating this issue.
Posted Aug 28, 2025 - 00:14 EDT
This incident affects: API (WS2).