Binance Smart Chain Lag
Incident Report for TRM Labs
Resolved
Our systems recovered.
Posted Jul 10, 2024 - 09:19 EDT
Identified
Root cause identified, our systems are currently recovering
Posted Jul 10, 2024 - 07:15 EDT
Investigating
We're experiencing a lag on BSC, we are actively investigating the root cause
Posted Jul 10, 2024 - 06:15 EDT