Brief spike in error rates across Graph Visualizer, Wallet Screening and Transaction Monitoring.

Incident Report for TRM Labs

Resolved

We identified an infrastructure node upgrade that rotated database proxy pods during the incident window. The pods did not drain connections cleanly, concentrating reconnects on replacement pods and causing database query read timeouts. A fix is being actively pushed.

Customer impact remains resolved.
Posted Aug 27, 2026 - 21:56 EDT

Investigating

A cross-service error-rate spike affected Transaction Monitoring, Graph Visualizer, and Wallet Screening for approximately 15 mins between 22:23–22:38 UTC (6:23–6:38pm EDT).

The spike has subsided and the current error rate is now low. The team is investigating the root cause.
Posted Aug 27, 2026 - 19:01 EDT
This incident affected: US (US - Forensics on Web, US - API - Wallet Screening, US - API - Transaction Monitoring).