Degraded Transaction Query Performance

Incident Report for TRM Labs

Resolved

This incident has been resolved.
Posted Aug 21, 2026 - 14:33 EDT

Monitoring

Monitoring: degraded Graph Visualizer transaction queries

The issue affecting transaction-based Graph Visualizer plots has been resolved. Requests to the transaction query endpoint are now responding normally, and Graph Visualizer plots should load as expected.

We'll continue monitoring the service and are also completing a longer-term fix to prevent the issue from recurring.

We're sorry for the disruption.
Posted Aug 21, 2026 - 13:21 EDT

Update

Investigating: degraded Graph Visualizer transaction queries

We’re continuing to investigate slow responses and intermittent timeouts affecting transaction-based plots in Graph Visualizer. Requests involving multiple transactions may take up to 30 seconds to complete or may fail, causing some plots to load slowly or not render.

Our engineering team has identified and is applying a fix. We’re aiming to restore normal performance within approximately one hour. We’ll provide another update when the fix is deployed and verified.
Posted Aug 21, 2026 - 11:49 EDT

Update

We’re investigating slow responses and elevated errors affecting the transactions feature and API endpoint. Requests involving multiple transactions may take up to 30 seconds to complete or may fail with a timeout, which can cause plotting and transaction-query features in GV to load slowly or fail.
Posted Aug 21, 2026 - 11:13 EDT

Update

We are continuing to investigate this issue.
Posted Aug 21, 2026 - 11:12 EDT

Investigating

We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Aug 21, 2026 - 10:53 EDT
This incident affected: US (US - Forensics on Web) and EU (EU - Forensics on Web).