Indirect risk is showing more indicators than expected

Incident Report for TRM Labs

Resolved

This incident has been resolved.
Posted Apr 25, 2025 - 16:18 EDT

Identified

We have identified the root cause and we are working on mitigating the issue.
Posted Apr 25, 2025 - 12:21 EDT

Investigating

We are investigating indirect risk indicators showing for some chains that is not expected.
Posted Apr 25, 2025 - 10:43 EDT
This incident affected: Forensics on Web and API (WS2).