Elevated Errors on Forensics

Incident Report for TRM Labs

Resolved

The incident is solved and we are seeing no errors on Forensics.
Posted Jul 16, 2025 - 18:14 EDT

Investigating

We are see elevated errors loading some APIs on Forensics. We are currently investigating the issue!
Posted Jul 16, 2025 - 18:02 EDT
This incident affected: Forensics on Web.