Intermittent issues with Public APIs

Incident Report for TRM Labs

Resolved

We've resolved the intermittent issues with our Wallet Screening and Transaction Monitoring APIs.
Posted Jun 11, 2025 - 10:40 EDT

Identified

We have identified the root cause and implementing a fix
Posted Jun 11, 2025 - 09:43 EDT

Investigating

Investigating intermittent issues with our Wallet Screening and Transaction Monitoring APIs.
Posted Jun 11, 2025 - 09:00 EDT
This incident affected: API (TM2, WS2).