Between 4:19:54pm and 4:38:58pm EDT on 1 September 2026, some US Wallet Screening requests failed or experienced degraded performance, including address screening and related risk and attribution lookups. Impact in the EU was negligible.
The issue has been resolved. Service recovered at approximately 4:39pm EDT, and subsequent monitoring confirmed normal traffic and error rates. A mitigation has been deployed and tested to reduce the risk of recurrence.
We apologize for the disruption.
Posted Sep 01, 2026 - 19:05 EDT
Update
We have isolated the issue to database saturation that caused supporting queries to exceed their timeout threshold. We are continuing to monitor the service and will provide another update on root cause.
Posted Sep 01, 2026 - 17:16 EDT
Monitoring
Some Wallet Screening requests failed or experienced degraded performance between approximately 3:01pm and 3:42pm CDT on 1 September 2026. Affected requests included address screening and related risk and attribution lookups.
The issue has been mitigated, and error rates returned to normal at approximately 3:42pm CDT. We are continuing to monitor the service and reviewing the underlying data-serving transition process to help prevent recurrence.
Posted Sep 01, 2026 - 16:52 EDT
This incident affected: US (US - API - Wallet Screening) and EU (EU - API - Wallet Screening).