Elevated API Errors

Incident Report for TRM Labs

Resolved

This incident has been resolved.
Posted Aug 22, 2026 - 07:31 EDT

Monitoring

The elevated API errors affecting some API Insights routes have subsided, and we are currently monitoring the service. During the incident, some requests experienced delays or 30-second timeouts.

Engineering and our database team are continuing to monitor the system.
Posted Aug 22, 2026 - 00:35 EDT

Investigating

We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Aug 21, 2026 - 23:59 EDT