Forensics is experiencing degraded performance

Incident Report for TRM Labs

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 15:28 EDT

Monitoring

All systems are operational. We continue to monitor the situation.
Posted Jun 13, 2025 - 15:02 EDT

Identified

We've identified the issue as due to a system failover. We're actively working on a mitigation.
Posted Jun 13, 2025 - 15:01 EDT

Update

We're currently investigating issues with Forensics and Wallet Screening.
Posted Jun 13, 2025 - 14:59 EDT

Investigating

We're currently investigating issues with Forensics being slow.
Posted Jun 13, 2025 - 14:51 EDT
This incident affected: Forensics on Web and API (WS2).