Cloudflare issues impacting TRM APIs

Incident Report for TRM Labs

Resolved

Cloudflare has confirmed that the incident has been fully resolved. Our services have remained stable since their remediation, and we are no longer observing any related errors or impact.

This issue is now considered resolved. We will continue routine monitoring to ensure continued system performance.
Posted Dec 05, 2025 - 13:58 EST

Monitoring

We have confirmed reports of a brief Cloudflare outage. They had an incident they reported on and closed that impacted our APIs.
https://www.cloudflarestatus.com/incidents/lfrm31y6sw9q

This issue has been resolved and we are observing no ongoing evidence of issues.

We are continuing to monitor this to ensure no impacts.
Posted Dec 05, 2025 - 06:12 EST

Investigating

We are investigating reports of ongoing Cloudflare issues disrupting access to our systems.
Posted Dec 05, 2025 - 05:24 EST
This incident affected: API (TM2, WS2).