Partial outage on TRM services
Incident Report for TRM Labs
Resolved
This incident has been resolved.
Posted Sep 27, 2024 - 02:00 EDT
Investigating
We are currently investigating this issue.
Posted Sep 27, 2024 - 01:40 EDT
This incident affected: Forensics on Web, Detect and API (TM2, WS2).