Wallet Screening API - degraded performance detected

Incident Report for TRM Labs

Resolved

We've identified the root cause and have implemented a fix.
Posted Sep 03, 2026 - 22:59 EDT

Update

We are continuing to monitor for any further issues.
Posted Sep 03, 2026 - 21:08 EDT

Monitoring

We are investigating an issue causing an elevated rate of HTTP errors for Wallet Screening.

The issue has been mitigated, and our engineering team is actively assessing the scope and cause of the issue.
Posted Sep 03, 2026 - 20:49 EDT
This incident affected: US (US - API - Wallet Screening) and EU (EU - API - Wallet Screening).