Some parts of Forensics were not displaying the full transaction information
Incident Report for TRM Labs
Resolved
Team is actively working on mitigating the issue, and should be resolved in the next 24 hours
Posted Jul 12, 2024 - 21:58 EDT
Identified
Team is actively working on mitigating the issue, and should be resolved in the next 24 hours
Posted Jul 11, 2024 - 19:14 EDT
This incident affected: Forensics on Web.